[Tuto] Automatiser son propre XML avec Wb+Plus.

XML TV Fr est un XML TV contenant la plupart des chaines francophones et quelques chaines étrangères.
Avatar du membre
remysimpson
Modérateur
Modérateur
Messages : 2100
Enregistré le : ven. 26 août 2016 15:42

Re: [Tuto] Créer automatiquement son propre XML avec Wb+Plus. **En cours d'élaboration**

Message par remysimpson » jeu. 13 févr. 2020 19:26

MetallixX974 a écrit :
jeu. 13 févr. 2020 18:57
logounet a écrit :
jeu. 13 févr. 2020 16:05
hi,

Super boulot que vous faites la tous les 2 (bravo)
Mais peut-on avoir plus de chaines ex: Warner, Polar+ etc... bref Canalsat chaines en Français, car la c'est Orange et non Télérama dans "WebGrab++.config.xml"

merci en tout cas
je vais tester cela avec le tuto

@+
Salut,

Effectivement c'est Orange, c'est juste une source mais effectivement je ferai des test avec telerama. Le but étant aussi que la plupart module son "WebGrab++.config.xml" à votre sauce. (pouce).

(bye)
telerama marche pas chez moi en local en tout cas
Tu as ete la pour moi depuis tout petit j'ai ete la jusqu'a ton dernier souffle

je t'aime mamie (love)
Avatar du membre
MetallixX974
Fan de series des années 90
Fan de series des années 90
Messages : 49
Enregistré le : mar. 11 oct. 2016 02:25

Re: [Tuto] Créer automatiquement son propre XML avec Wb+Plus. **En cours d'élaboration**

Message par MetallixX974 » jeu. 13 févr. 2020 20:11

Telerama fonctionne je crois avoir trouvé... Je dis bien je suppose.

Aller ici : Ici.

Télécharger les 3 fichiers zip : 1) telerama.fr.api 2)telerama.fr et 3)telerama.fr.index-only

Les dezipper dans le fichier "siteini.pack\France" de Webgrab, confirmer le remplacement des fichiers.

Ouvrir le fichier "telerama.fr.channels" et copier coller toutes ce qui se trouve entre les balises <channels> </channels> dans votre fichier "WebGrab++.config"

Sauvegarder et lancer WebGrab+plus.

Ça devrait fonctionner. Perso j'ai copier les deux premiers fichiers zip uniquement ( donc 4 fichiers à remplacer ) et là ça grab tranquille. (oui)

J'ai juste quelques erreurs sur quelques chaines sur les 300+... mais je vais faire d'avantage de test...

J'ai profité pour rajouter quelques chaines prises en charge dans le fichier webgrab++.conf Voir 1er post.
Z69 Max : 64 Go de Rom - 3 Go Ram -Amlogic S912 (cool) - Petit nouveau dans la famille : Beelink GT-King Pro @Amlogic S922X-H - 4 Go de Ram - 64 Go de Rom (lolol) . Amlogic fan (love).
Avatar du membre
logounet
Zapeur Fou !
Zapeur Fou !
Messages : 164
Enregistré le : sam. 22 avr. 2017 17:16

Re: [Tuto] Créer automatiquement son propre XML avec Wb+Plus. **En cours d'élaboration**

Message par logounet » jeu. 13 févr. 2020 21:57

MetallixX974 a écrit :
jeu. 13 févr. 2020 20:11
Telerama fonctionne je crois avoir trouvé... Je dis bien je suppose.

J'ai profité pour rajouter quelques chaines prises en charge dans le fichier webgrab++.conf Voir 1er post.
Hi,

Perso que des erreur "canal sécurisé SSL/TTL" sur tes chaines rajoutées sous "telerama.fr"

Sous Orange cela fonctionne nickel

@+
Image
Avatar du membre
MetallixX974
Fan de series des années 90
Fan de series des années 90
Messages : 49
Enregistré le : mar. 11 oct. 2016 02:25

Re: [Tuto] Créer automatiquement son propre XML avec Wb+Plus. **En cours d'élaboration**

Message par MetallixX974 » jeu. 13 févr. 2020 22:04

logounet a écrit :
jeu. 13 févr. 2020 21:57
MetallixX974 a écrit :
jeu. 13 févr. 2020 20:11
Telerama fonctionne je crois avoir trouvé... Je dis bien je suppose.

J'ai profité pour rajouter quelques chaines prises en charge dans le fichier webgrab++.conf Voir 1er post.
Hi,

Perso que des erreur "canal sécurisé SSL/TTL" sur tes chaines rajoutées sous "telerama.fr"

Sous Orange cela fonctionne nickel

@+
(oh) Ha je comprends pas... pourtant regarde chez moi impecable... Ici.

As-tu essayé les manips dans mon post précédent?
Z69 Max : 64 Go de Rom - 3 Go Ram -Amlogic S912 (cool) - Petit nouveau dans la famille : Beelink GT-King Pro @Amlogic S922X-H - 4 Go de Ram - 64 Go de Rom (lolol) . Amlogic fan (love).
Avatar du membre
logounet
Zapeur Fou !
Zapeur Fou !
Messages : 164
Enregistré le : sam. 22 avr. 2017 17:16

Re: [Tuto] Créer automatiquement son propre XML avec Wb+Plus. **En cours d'élaboration**

Message par logounet » jeu. 13 févr. 2020 22:18

hi,

Oui même manip et que nenni erreurs sous "Télérama"

Pourrais tu poster ton "guide.xml" une fois terminé StP?

merci d'avance

PS: C bon avec webgrabplus 2.1.11 car ton lien est pour la version "2.1 qui donne des erreurs"
En regardant ta vidéo sur ton post précédent toi tu as la version 2.1.9

webgrabplus 2.1.11

Donc voila

merci pour tout
Image
Avatar du membre
MetallixX974
Fan de series des années 90
Fan de series des années 90
Messages : 49
Enregistré le : mar. 11 oct. 2016 02:25

Re: [Tuto] Créer automatiquement son propre XML avec Wb+Plus. **En cours d'élaboration**

Message par MetallixX974 » jeu. 13 févr. 2020 22:58

(bravo) Haaaa... Bon bah ok je vais modifier mon 1er Post... Merci Logounet (aniv) (pouce) Comme quoi 4 yeux vaut mieux que 2. (aha)

Voici un exemple de guide tout frais valide 24h.

guide.xml
Z69 Max : 64 Go de Rom - 3 Go Ram -Amlogic S912 (cool) - Petit nouveau dans la famille : Beelink GT-King Pro @Amlogic S922X-H - 4 Go de Ram - 64 Go de Rom (lolol) . Amlogic fan (love).
Avatar du membre
logounet
Zapeur Fou !
Zapeur Fou !
Messages : 164
Enregistré le : sam. 22 avr. 2017 17:16

Re: [Tuto] Créer automatiquement son propre XML avec Wb+Plus. **En cours d'élaboration**

Message par logounet » ven. 14 févr. 2020 00:06

hi,

De rien, je fais des tests sous "Telecablesat" cela fonctionne impec

@+
Image
Avatar du membre
mezzy
Addict de Canal+Cinéma
Addict de Canal+Cinéma
Messages : 79
Enregistré le : mar. 16 août 2016 05:00

Re: [Tuto] Créer automatiquement son propre XML avec Wb+Plus. **En cours d'élaboration**

Message par mezzy » ven. 14 févr. 2020 04:37

salut all

je recontre des erreurs malgré les manip mentionnées avec telerama ( tests sous v2.1.9 et 2.1.11 avec le nouveau config.xml) qui me donne erreurs SSL et no show index page

@logounet visiblement telerama fonctionne sous V2.1.11 peux tu confirmer?
@metallix je rencontre le meme probleme pour les chaines de TV5 monde
pourrais tu faire un test merci d'avance ( PS verifier si USA fonctionne j'ai mis eastern time mais pas tres sur)
et uploader le guide.xml résultant sous 8 jours

Code : Tout sélectionner

<?xml version="1.0" encoding="UTF-8"?>
<site generator-info-name="WebGrab+Plus/w MDB &amp; REX Postprocess -- version V1.56.25 -- Jan van Straaten" site="tv5monde.com">
  <channels>
    <channel update="i" site="tv5monde.com" site_id="france-belgique-suisse" xmltv_id="FBS">france</channel>
    <channel update="i" site="tv5monde.com" site_id="europe" xmltv_id="europe">allemagne</channel>
    <channel update="i" site="tv5monde.com" site_id="etats-unis" xmltv_id="usa">eastern time</channel>
    <channel update="i" site="tv5monde.com" site_id="maghreb-orient" xmltv_id="orient">mauritanie</channel>
    <channel update="i" site="tv5monde.com" site_id="amerique-latine-et-caraibes" xmltv_id="am-lat">haïti</channel>
    <channel update="i" site="tv5monde.com" site_id="asie" xmltv_id="asie">maldives</channel>
    <channel update="i" site="tv5monde.com" site_id="pacifique" xmltv_id="pacifique">japon</channel>
     </channels>
</site>
Par contre avec la toute récente maj de telecable ça a l'air ok
Avatar du membre
logounet
Zapeur Fou !
Zapeur Fou !
Messages : 164
Enregistré le : sam. 22 avr. 2017 17:16

Re: [Tuto] Créer automatiquement son propre XML avec Wb+Plus. **En cours d'élaboration**

Message par logounet » ven. 14 févr. 2020 08:56

mezzy a écrit :
ven. 14 févr. 2020 04:37
salut all

@logounet visiblement telerama fonctionne sous V2.1.11 peux tu confirmer?

Par contre avec la toute récente maj de telecable ça a l'air ok
hi,

Oui Télérama fonctionne sous 2.1.11

@+
Image
Avatar du membre
MetallixX974
Fan de series des années 90
Fan de series des années 90
Messages : 49
Enregistré le : mar. 11 oct. 2016 02:25

Re: [Tuto] Créer automatiquement son propre XML avec Wb+Plus. **En cours d'élaboration**

Message par MetallixX974 » ven. 14 févr. 2020 17:28

mezzy a écrit :
ven. 14 févr. 2020 04:37
salut all

je recontre des erreurs malgré les manip mentionnées avec telerama ( tests sous v2.1.9 et 2.1.11 avec le nouveau config.xml) qui me donne erreurs SSL et no show index page

@logounet visiblement telerama fonctionne sous V2.1.11 peux tu confirmer?
@metallix je rencontre le meme probleme pour les chaines de TV5 monde
pourrais tu faire un test merci d'avance ( PS verifier si USA fonctionne j'ai mis eastern time mais pas tres sur)
et uploader le guide.xml résultant sous 8 jours

Code : Tout sélectionner

<?xml version="1.0" encoding="UTF-8"?>
<site generator-info-name="WebGrab+Plus/w MDB &amp; REX Postprocess -- version V1.56.25 -- Jan van Straaten" site="tv5monde.com">
  <channels>
    <channel update="i" site="tv5monde.com" site_id="france-belgique-suisse" xmltv_id="FBS">france</channel>
    <channel update="i" site="tv5monde.com" site_id="europe" xmltv_id="europe">allemagne</channel>
    <channel update="i" site="tv5monde.com" site_id="etats-unis" xmltv_id="usa">eastern time</channel>
    <channel update="i" site="tv5monde.com" site_id="maghreb-orient" xmltv_id="orient">mauritanie</channel>
    <channel update="i" site="tv5monde.com" site_id="amerique-latine-et-caraibes" xmltv_id="am-lat">haïti</channel>
    <channel update="i" site="tv5monde.com" site_id="asie" xmltv_id="asie">maldives</channel>
    <channel update="i" site="tv5monde.com" site_id="pacifique" xmltv_id="pacifique">japon</channel>
     </channels>
</site>
Par contre avec la toute récente maj de telecable ça a l'air ok
:?: :?: :?: Tes sites ID sont vraiment très bizarre de plus sur le site WebGrab+Plus je ne vois pas les XML de Tv5monde. En allant sur le site TV5monde je ne vois pas non plus ces chaines... J'ai les mêmes erreurs que toi quand je test... No show in index page = Pas de programme dans le contenu de la page pointé (non) Je t'en dirai plus dès que je pourrai.
Z69 Max : 64 Go de Rom - 3 Go Ram -Amlogic S912 (cool) - Petit nouveau dans la famille : Beelink GT-King Pro @Amlogic S922X-H - 4 Go de Ram - 64 Go de Rom (lolol) . Amlogic fan (love).
Répondre